Back to overview
Downtime
Email in maintenance
Oct 04 at 05:20pm CEST
Affected services
Landing
Resolved
Oct 04 at 05:25pm CEST
Everything works ok now.
Affected services
Updated
Oct 04 at 05:22pm CEST
As it turns out, landing wasn't affected at all!
Affected services
Created
Oct 04 at 05:20pm CEST
Email server was down, so you might experience some issues performing common mail operations.
Affected services