Back to overview
Degraded
Incorrect certificate loading in for webador.fi
Dec 6, 2023 at 12:00am UTC
Affected services
Landing
Resolved
Dec 6, 2023 at 8:27am UTC
Correct certificate is now served
Affected services
Created
Dec 6, 2023 at 12:00am UTC
We are serving an incorrect certificate for webador.fi
Affected services