Back to overview
Downtime

MailChannels was unavailable

Jan 9, 2024 at 6:37pm UTC
Affected services
Email

Resolved
Jan 10, 2024 at 12:13am UTC

DNS cache was flushed, unbound was restart and everything started working again

Created
Jan 9, 2024 at 6:37pm UTC

MailChannels can't process any DNS requests